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1. INSTALLING AND LICENSING NDB EXPLORER 

Follow the instructions in the NDB Explorer Installation and Licensing Guide which is available 
to download from the NDB Explorer section of the Database Services website: 

https://www.geaerospace.com/systems/avionics/navigation-guidance/data-services 
 

2. CREATING AIRCRAFT LOADABLE MEDIA 

NDB Explorer can be used to create Aircraft Loadable Media from a GE Aviation Navigation 

Database. This function is shown at start up, but can also be accessed in Tools > Create 

Aircraft Loadable Media… 

 
 

NDB Explorer supports the generation of loadable media sets for use in ARINC 615 and ARINC 

665 data loaders. The media set can be written to the hard drive or to diskettes.  NDB Explorer 

will automatically provide available Media Types when an Image File is selected. 

ARINC 665 Target Hardware IDs can be defined in Tools > Preferences… > Create Media. 

The Create Navigation Database Identifier Subdirectory option will use the database 

identifier to create a uniquely identifiable top-level folder within the destination directory. 

The Split for Diskettes option will create diskette-sized folders directly to the hard drive. 

For additional guidance and troubleshooting about creating loadable media on diskettes, see 

Appendix A. 

https://www.geaerospace.com/systems/avionics/navigation-guidance/data-services
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3. OPENING A NAVIGATION DATABASE 

NDB Explorer will only open files that contain valid CRCs and a valid digital signature. To 

validate a loadable Fileset, simply open it with NDB explorer. 

•For an ARINC 615 file set on Hard Drive – Open the 1NAV_U5.ND file. 

•For an ARINC 615 file set on Diskettes – Open any of the 1NAV_U5.ND files. 

•For an ARINC 665 Platform Group A file set – Open the *.LUH file. 

•For an ARINC 665 Platform Group B file set – Open the *.LUH file. 

•For an ARINC 665 Platform Group C file set – Open the *.LUH file. 

By default, NDB Explorer will present the Navigation Databases window, which is docked on the 

left side of the application. All windows can be moved or floated. 

 

NDB explorer can open a GE Aviation Navigation Database, an aircraft loadable media set, a 

GE Aviation SQLite Export File, or a Gold Standard Database. This is accomplished either 

through File > Open…, or by dragging the file into the Navigation Databases window. 

Once a database is open, each AIRAC cycle will be available in the Navigation Databases 

window and a property grid will be displayed on the right side of the Home tab that contains 

each database cycle's metadata. 

Right-clicking on an open database cycle will display the available actions.  Show Home will 

open a new Navigation Database home tab. 
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4. EXPLORING YOUR NAVIGATION DATABASE 

Each open database cycle has a corresponding Home tab. The Home tab contains a search 

box, which will auto-fill based on the entered text. The results can be filtered using the drop-

down. Search for an airport to explore its terminal data. 

 

Once found, double-click on the airport to open a new tab. All the terminal data for that airport is 

displayed in a new tab. 

 

 

Database Definition Parameters can be viewed either by selecting Tools > View Database 

Definition Parameters or by right clicking on the Navigational Database and selecting View 

Database Definition Parameters.  You can view Customer Information, Geo Area Selections, 

and Airport Information selections. 
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Database Definition Parameters can be Exported by right clicking on the Navigation Database 

> Export To > PDF/SQLite > Check the Database Definition Parameters box (PDF 

selection only). 

5. EXPORTING YOUR NAVIGATION DATABASE 

5.1 EXPORT TO SQLITE 

The Navigation Database Export to SQLite File is intended to provide a machine-readable view 

of the data, to be ingested by custom tools and applications for things like RNP-AR procedure 

validation, flight planning, and simulation support. 

The database engine used is SQLite, a small, fast, self-contained, high-reliability, full-featured, 

SQL database engine. There are libraries available in many languages to access the data. 

Export your navigation database via Tools > Export To > SQLite… The Tasks window will 

appear and indicate when the export is complete. 

Once exported, any database browsing application compatible with SQLite can be used to open 

the SQLite file. 

For information on the format of the data tables, the Data Dictionary for the SQLite Navigation 

Database Export Format is available in Tools > Export to > SQLite… > Get Data Dictionary. 

In addition to the data tables, there are database views available for each procedure type to 

promote readability (v_procedure type_legs). 

 

https://www.sqlite.org/index.html


  

GE Designated: NON-PUBLIC – may release with approval only 7 
Use or disclosure of data contained on this sheet is subject to the restrictions on the cover or first page. 

 

5.2 EXPORT TO PDF 

The Navigation Database Export to PDF file is intended to provide a human-readable view of 

the data contained in either the old or the new cycle of your Navigation Database. 

Export your navigation database via Tools > Export to > PDF... Select the destination of your 

report and the data type(s) that you would like included in the report. The Tasks window will 

appear and indicate when the export is complete. 

Once exported, any PDF reader application can be used to open the PDF file. 
 
 

6. COMPARING NAVIGATION DATABASES 
NDB Explorer can compare GE Aviation Navigation Databases, aircraft loadable media sets, 

GE Aviation SQLite Export Files, or Gold Standard Databases to one another. This is 

accomplished either through Tools > Compare..., or right-clicking on an open database cycle. 

Add one navigation database on the left and another navigation database on the right. Select 

the data types to be compared and click OK. The Tasks window will appear and indicate when 

the Compare is complete. In addition to comparing the individual data types, NDB Explorer can 

compare on Tailored or RNP-AR procedures only. 
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The colored buttons at the top of the Compare tab allow filtering of unchanged , changed , 

left-side only , and right-side only  data. 

To view the specific changes, expand a datatype and click on the record. 

 
 

7. GOLD STANDARD DATABASES 
Known good data can be imported into a separate database file, called a Gold Standard 

Database, for easy procedure monitoring and efficient RNP-AR validation. A Gold Standard 

Database can be established through Tools > Gold Standard Database > New… 

To import data into a gold standard database, compare the Gold Standard Database to a 

Navigation Database. Right-click on the record to be imported and select Import data to 

database. 

 

After a Gold Standard Database is established, new databases can be compared and any 

changes identified. The newly validated data can then overwrite the previous obsolete data.  

file:///D:/Apps/NDBIT/WebHelp/Compare_Database_Operations.htm%23Gold_Std_Database_Compare_Description
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Date, time, and comment history of every change is stored in the Gold Standard Database. This 

history can be viewed by browsing to each record within the Gold Standard Database. 

 
 

8. VIEWING THE LATERAL PATH 

NDB Explorer displays a top-down graphical lateral path of the procedures, airways, and 
company routes in your NDB. The lateral path is overlaid on a map which is populated with 
background data also extracted directly from your NDB. 
 
The background data symbols are derived from the FAA’s Aeronautical Chart User’s Guide. 
 

https://www.faa.gov/air_traffic/flight_info/aeronav/digital_products/aero_guide/


  

GE Designated: NON-PUBLIC – may release with approval only 10 
Use or disclosure of data contained on this sheet is subject to the restrictions on the cover or first page. 

 

 
 
NDB Explorer can also export the displayed lateral path to a KML file, which can be viewed in 
Google EarthTM. Google Earth™ is a trademark of Google LLC. 
 
9. LICENSABLE FEATURES AND SUPPORT 
The following features require an additional software Premium License: 

• Viewing the Lateral Path 

• Exporting to SQLite and PDF 

• Comparing 2 different navigation databases 

• Comparing a navigation database to a Gold Standard Database 

To extend an existing software license, request a free NDB Explorer Premium License trial, or   
for technical support please visit the Systems Navigation & Guidance – Contact Us page. 

https://developers.google.com/kml/
https://www.google.com/earth/
https://geaviationsystems.my.salesforce-sites.com/
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A. APPENDIX A: CREATING LOADABLE MEDIA ON DISKETTES 

Floppy disks and floppy drives are an aging medium and can cause issues when loading 
databases. If it is at all possible, it is recommended to use alternatives to floppy disks when 
loading Navigation Databases. GE Aviation has tested many datasets on newly purchased 
floppy disks and found that the failure rate of an individual floppy disk was approximately 30%. If 
it is unavoidable to use floppy disks, GE Aviation recommends following manufacturer guidance 
for cleaning and maintaining floppy disks and floppy drives. This includes floppy drives used to 
generate the loadable media, the 615 data loader and the floppy disks themselves. It is 
recommended that you check with your aircraft manufacturer and data loader manufacturer for 
upgrade options. 
 
To use NDB Explorer to generate loadable media on floppy disks, select ARINC 615 Media to 
Diskette(s). Select your Image File and the Destination Floppy Drive. If any disk already 
contains files, NDB Explorer will erase them. Follow the prompts from NDB Explorer until the 
media set is successfully created. 
 
If you typically have issues with floppies, it is recommended that you confirm the floppy disks 
were written successfully by loading the media set written on the floppy disks back into NDB 
Explorer. To do this, see: Opening a Navigation Database. If NDB Explorer fails to open the 
media set, it is likely you have a bad floppy disk. Regenerate the media set and replace the 
physical floppy disk that failed to load. Note that the media set being loaded by NDB Explorer 
verifies that database was successfully written to the diskette(s) but does not guarantee it will 
load on the aircraft due to the unreliability of floppy disks.  
 

A.1 FLOPPY TROUBLESHOOTING GUIDANCE 

If, after generating the media set and verifying it can load in NDB Explorer, there are still issues 
loading the media set to the aircraft, here are some general guidelines other users have used 
and have had some success with. These tips are not guaranteed to resolve all loading issues 
but have been helpful in the past. 
 

1.) Try reaching out to the aircraft manufacturer and determine if it is possible to use another 
medium other than floppy disks to load your Navigation Database. If it is not, investigate 
possible upgrades to your hardware that are no longer dependent on floppy disks. 

 
2.) Try to clean the hardware responsible for generating and loading the media. This 

includes, but is not limited to, the floppy drive, the data loader and the floppy disks 
themselves. Contact the manufacturer and follow their guidance for cleaning any and all 
devices.  
 

3.) Try generating multiple copies of the floppy media set to bring out to the plane. This will 
allow swapping out disks that may fail during loading. For instance, if disk 3 fails, you 
can retry by replacing disk 3 with another disk 3 from an identical media set.  
 

4.) Try checking all your floppy disks for bad sectors. This can help you eliminate faulty 
floppy disks. See section 2.1.2 for guidance on how to check a floppy for bad sectors. 
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5.) Try formatting the floppy disks. This can be done by right clicking on the floppy drive with 
a floppy disk in it and clicking “Format…”. Users have used Quick and Full Formats. 

 

A.2 CHECKING A FLOPPY FOR BAD SECTORS 

This should only be done by advanced users looking to determine if their floppy disk has 
detectable bad sectors. 
 
Open the “Run” dialog in Windows by pressing Windows key + R. In the dialog, type in “cmd”. 
 

 
 
A command window will be displayed. From here, type “A:” (or the appropriate drive letter 
corresponding to your floppy drive). Hit enter. Next, type “chkdsk” and hit enter. The results will 
look like the following: 
 

 
 
Look for the text “bad sectors” in the chkdsk results. 
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It is recommended to replace any disk containing bad sectors. 


